Constructs a new instance of a CustomExporter for a given document
using the input instance of IExportContext as the output device.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since:
2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The document containing the model to be exported
- context
-
Type:
Autodesk.Revit.DB
IExportContext
An instance of a context class that will be consuming the output
Remarks
The input context should be an instance of a class that implements
either
IModelExportContext
or
IPhotoRenderContext
interfaces.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |