CanHaveUnitSymbol Method


Checks whether a unit symbol can be specified for the display unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `CanHaveSymbol()` method instead.")]
public bool CanHaveUnitSymbol()
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `CanHaveSymbol()` method instead.")> _
Public Function CanHaveUnitSymbol As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `CanHaveSymbol()` method instead.")]
public:
bool CanHaveUnitSymbol()

Return Value

True if a unit symbol can be specified, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException UseDefault is true in this FormatOptions.

See Also