GetSweptProfile Method


Gets the object that describes the profile that is swept along the driving curve for this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public SweptProfile GetSweptProfile()
Visual Basic
Public Function GetSweptProfile As SweptProfile
Visual C++
public:
SweptProfile^ GetSweptProfile()

Return Value

A swept profile.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InapplicableDataException Thrown if this instance does not have a swept profile.

See Also