ConvertFromInternalUnits Method


Converts a value from Revit's internal units to a given display unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `ConvertFromInternalUnits(double, ForgeTypeId)` overload instead.")]
public static double ConvertFromInternalUnits(
	double value,
	DisplayUnitType displayUnit
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `ConvertFromInternalUnits(double, ForgeTypeId)` overload instead.")> _
Public Shared Function ConvertFromInternalUnits ( _
	value As Double, _
	displayUnit As DisplayUnitType _
) As Double
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `ConvertFromInternalUnits(double, ForgeTypeId)` overload instead.")]
public:
static double ConvertFromInternalUnits(
	double value, 
	DisplayUnitType displayUnit
)

Parameters

value
Type: System Double
The value to convert.
displayUnit
Type: Autodesk.Revit.DB DisplayUnitType
The desired display unit.

Return Value

The converted value.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The given value for value is not finite -or- displayUnit is an invalid display unit. See UnitUtils.IsValidDisplayUnit(DisplayUnitType) and UnitUtils.GetValidDisplayUnits().
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also