RebarShapeConstraintArcLength Constructor


Create an arc-length constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public RebarShapeConstraintArcLength(
	ElementId paramId
)
Visual Basic
Public Sub New ( _
	paramId As ElementId _
)
Visual C++
public:
RebarShapeConstraintArcLength(
	ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB ElementId
The Id of a Rebar Shape parameter.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also