LoadFamilySymbol Method (String, String, FamilySymbol)


Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public bool LoadFamilySymbol(
	string filename,
	string name,
	out FamilySymbol symbol
)
Visual Basic
Public Function LoadFamilySymbol ( _
	filename As String, _
	name As String, _
	<OutAttribute> ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
	String^ filename, 
	String^ name, 
	[OutAttribute] FamilySymbol^% symbol
)

Parameters

filename
Type: System String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System String
The name of the type/symbol to be loaded, such as "W11x14".
symbol
Type: Autodesk.Revit.DB FamilySymbol %
A reference to the family symbol that was loaded if successful, otherwise a null reference ( Nothing in Visual Basic) .

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

This function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Thrown when filename or name is a null reference ( Nothing in Visual Basic) or empty.

See Also