Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
If LockProportions is true, then changes to the HeightScale will also result in changes to the WidthScale .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | When setting this property: The given value for heightScale results in a height that is more than 30000 feet. -or- When setting this property: The given value for heightScale results in a width that is more than 30000 feet because LockProportions is set to true. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | When setting this property: The given value for heightScale must be non-negative. |