IsSymbol Method


Checks whether a ForgeTypeId identifies a symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public static bool IsSymbol(
	ForgeTypeId symbolTypeId
)
Visual Basic
Public Shared Function IsSymbol ( _
	symbolTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool IsSymbol(
	ForgeTypeId^ symbolTypeId
)

Parameters

symbolTypeId
Type: Autodesk.Revit.DB ForgeTypeId
The identifier to check.

Return Value

True if the ForgeTypeId identifies a symbol, false otherwise.

Remarks

A ForgeTypeId identifies a symbol if it corresponds to a UnitSymbolType value according to UnitUtils.GetSymbolTypeId(UnitSymbolType) .

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also