GetCustomConstraints Method


Gets all rebar constraints that are attached to custom handles for this rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018

Syntax

C#
public IList<RebarConstraint> GetCustomConstraints()
Visual Basic
Public Function GetCustomConstraints As IList(Of RebarConstraint)
Visual C++
public:
IList<RebarConstraint^>^ GetCustomConstraints()

Return Value

Returns all rebar constraints that are attached to custom handles for this rebar. This array does not contains the start and end constraints.

See Also