GetHookExtensionLength Method


Computes the hook extension length based on current hook length

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public double GetHookExtensionLength(
	RebarBarType barType
)
Visual Basic
Public Function GetHookExtensionLength ( _
	barType As RebarBarType _
) As Double
Visual C++
public:
double GetHookExtensionLength(
	RebarBarType^ barType
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also