SetCombinedParameters Method


Sets combined parameters array.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021

Syntax

C#
public void SetCombinedParameters(
	IList<TableCellCombinedParameterData> data
)
Visual Basic
Public Sub SetCombinedParameters ( _
	data As IList(Of TableCellCombinedParameterData) _
)
Visual C++
public:
void SetCombinedParameters(
	IList<TableCellCombinedParameterData^>^ data
)

Parameters

data
Type: System.Collections.Generic IList TableCellCombinedParameterData
The array of TableCellCombinedParameterData to be set as combined parameters.

Remarks

Currently the following parameters are supported:

  • Shared Parameters
  • RBS_ELEC_CIRCUIT_NAME
  • RBS_ELEC_CIRCUIT_PANEL_PARAM
  • RBS_ELEC_CIRCUIT_TYPE
  • CIRCUIT_LOAD_CLASSIFICATION_ABBREVIATION_PARAM
  • RBS_ELEC_CIRCUIT_NAMING_INDEX
  • RBS_ELEC_NUMBER_OF_POLES
  • RBS_ELEC_CIRCUIT_RATING_PARAM
  • RBS_ELEC_CIRCUIT_FRAME_PARAM
  • RBS_ELEC_VOLTAGE
  • CIRCUIT_PHASE_PARAM
  • CIRCUIT_WAYS_PARAM
  • RBS_ELEC_CIRCUIT_SLOT_INDEX

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The data contains invalid parameter id.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also