GetParameterTypeId Method


Tests whether this definition identifies a built-in parameter or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)

Syntax

C#
public ForgeTypeId GetParameterTypeId()
Visual Basic
Public Function GetParameterTypeId As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetParameterTypeId()

Remarks

For a built-in parameter this method returns one of the ParameterTypeId static properties. For custom-defined parameters, such as shared, global, or family parameters the value is null.

See Also