Sets the analytical model projection to a preset value.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure AnalyticalElementSelector
End of the analytical model.
- planeIdY
- Type: Autodesk.Revit.DB ElementId
Plane on to which analytical model may be projected in Y direction. Plane identifies a Level, a Grid, or a Ref Plane.
- planeIdZ
- Type: Autodesk.Revit.DB ElementId
Plane on to which analytical model may be projected in Z direction. Plane identifies a Level, a Grid, or a Ref Plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |