Indicates if the identified reference is acceptable for Manual Analytical Adjustment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- reference
- Type: Autodesk.Revit.DB Reference
Reference that will be examined.
Return Value
True if reference can be used, false otherwise.Remarks
This method is useful to determine if a reference is acceptable for Manual Analytical Adjustment in general. This looks briefly at the reference, without looking at the specific context.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment. |