GetValidTypes Method


Obtains a set of types that are valid for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public ICollection<ElementId> GetValidTypes()
Visual Basic
Public Function GetValidTypes As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetValidTypes()

Return Value

A set of element IDs of types that are valid for this element or an empty set if element cannot have type assigned.

See Also