NewRoom Method (Phase)


Creates a new unplaced room and with an assigned phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
public Room NewRoom(
	Phase phase
)
Visual Basic
Public Function NewRoom ( _
	phase As Phase _
) As Room
Visual C++
public:
Room^ NewRoom(
	Phase^ phase
)

Parameters

phase
Type: Autodesk.Revit.DB Phase
The phase in which the room is to exist.

Return Value

If successful the new room , otherwise a null reference ( Nothing in Visual Basic) .

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Thrown if the phase does not exist in the given document.

See Also