ViewSchedule Class


A schedule view. For proxy DBViewSchedule which is used for linked documents, the host document needs to be cached. Because the ScheduleFilter or ConditionalFormatOptions in the proxy ScheduleSchema might have an ElementId value referencing an element in host document. For such cases, the host document is needed in order to format this ElementId value to a string in the proxy ScheduleSchema.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013

Syntax

C#
public class ViewSchedule : TableView
Visual Basic
Public Class ViewSchedule _
	Inherits TableView
Visual C++
public ref class ViewSchedule : public TableView

Remarks

The ViewSchedule class represents schedules and other schedule-like views, including single-category and multi-category schedules, key schedules, material takeoffs, view lists, sheet lists, keynote legends, revision schedules, and note blocks. The ViewSchedule class is not used for panel schedules (see PanelScheduleView) or graphical column schedules.

A schedule is a tabular representation of data. A typical schedule shows all elements of a category (doors, rooms, etc.) with each row representing an element and each column representing a parameter. This basic structure can be modified using filters, sorting, grouping, totals, formulas, and other features.

The ScheduleDefinition class contains most settings that determine the contents of a schedule, including category, fields, filters, and sorting.

A graphical representation of a schedule can be placed on a sheet using the ScheduleSheetInstance class.

Inheritance Hierarchy

See Also