Creates a new LoadCase.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The Document to which new load case element will be added.
- name
- Type: System String
The name of the load case.
- natureId
- Type: Autodesk.Revit.DB ElementId
The load nature ID.
- subcategoryId
- Type: Autodesk.Revit.DB ElementId
The load case subcategory ID. Could be one of predefined or user defined load case category. Built-in structural Load Cases ( OST_LoadCases ) subcategories are: OST_LoadCasesDead OST_LoadCasesLive OST_LoadCasesWind OST_LoadCasesSnow OST_LoadCasesRoofLive OST_LoadCasesAccidental OST_LoadCasesTemperature OST_LoadCasesSeismic
Return Value
The newly created load case element if successful, a null reference ( Nothing in Visual Basic) otherwise.Remarks
This method is designed to create LoadCase that is associated with user defined category.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given name is not unique. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |