An object that represents an Path Reinforcement within the Autodesk Revit project.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
Remarks
This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.
Examples

private void Getinfo_PathReinforcement(PathReinforcement pathReinforcement)
{
string message = "PathReinforcement : ";
// Show the NumBarDescriptions property
IList<ElementId> rebarInSystemIds = pathReinforcement.GetRebarInSystemIds();
message += "\nNumber of distinct bar shapes : " + rebarInSystemIds.Count;
for (int i = 0; i < rebarInSystemIds.Count; i++)
{
RebarInSystem ris = doc.GetElement(rebarInSystemIds[0]) as RebarInSystem;
message += "\nBar count : " + ris.Quantity;
message += "\nBar type name : " + ris.Name;
message += "\nBar length : " + ris.LookupParameter("Bar Length").AsDouble();
}
// Show the PathReinforcement Curves information
IList<ElementId> curveIds = pathReinforcement.GetCurveElementIds();
message += "\nPath Reinforcement has " + curveIds.Count + " path curves.";
foreach (Autodesk.Revit.DB.ElementId ii in curveIds)
{
ModelCurve pathCurve = doc.GetElement(ii) as ModelCurve;
if (null == pathCurve)
{
continue;
}
Curve curve = pathCurve.GeometryCurve; // get the location curve
XYZ start = curve.GetEndPoint(0); // get the start point of the curve
XYZ end = curve.GetEndPoint(1); // get the end point of the curve
message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
message += " End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
}
TaskDialog.Show("Revit", message);
}

Private Sub Getinfo_PathReinforcement(pathReinforcement As PathReinforcement)
Dim message As String = "PathReinforcement : "
' Show the NumBarDescriptions property
Dim rebarInSystemIds As IList(Of ElementId) = pathReinforcement.GetRebarInSystemIds()
message += vbLf & "Number of distinct bar shapes : " & rebarInSystemIds.Count
For i As Integer = 0 To rebarInSystemIds.Count - 1
Dim ris As RebarInSystem = TryCast(doc.GetElement(rebarInSystemIds(0)), RebarInSystem)
message += vbLf & "Bar count : " + ris.Quantity
message += vbLf & "Bar type name : " + ris.Name
message += vbLf & "Bar length : " & ris.LookupParameter("Bar Length").AsDouble()
Next
' Show the PathReinforcement Curves information
Dim curveIds As IList(Of ElementId) = pathReinforcement.GetCurveElementIds()
message += vbLf & "Path Reinforcement has " & curveIds.Count & " path curves."
For Each ii As Autodesk.Revit.DB.ElementId In curveIds
Dim pathCurve As ModelCurve = TryCast(doc.GetElement(ii), ModelCurve)
If pathCurve Is Nothing Then
Continue For
End If
Dim curve As Curve = pathCurve.GeometryCurve
' get the location curve
Dim start As XYZ = curve.GetEndPoint(0)
' get the start point of the curve
Dim [end] As XYZ = curve.GetEndPoint(1)
' get the end point of the curve
message += ((vbLf & "Curve: Start point (" + start.X & ", ") + start.Y & ", ") + start.Z & ")"
message += ((" End point (" + [end].X & ", ") + [end].Y & ", ") + [end].Z & ")"
Next
TaskDialog.Show("Revit", message)
End Sub