Identifies whether or not the section box is active in this 3D view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
An active section box clips the geometry of the model in the 3D view. This affects the appearance of the view, and also will affect information returned from the API. For example:- Elements outside the active section box will not be returned in the list of elements obtained from [!:Autodesk::Revit::DB::FilteredElementCollector] when this view is passed when contructing the collector.
- Elements clipped by the active section box will return clipped geometry from Geometry Options when this view is included in the options.
Examples

private void DisableSectionBox(View3D view3d)
{
if (!view3d.IsSectionBoxActive)
{
TaskDialog.Show("Revit", "The section box for View3D isn't active.");
return;
}
// Disable the section box (requires an open transaction)
view3d.IsSectionBoxActive = false;
}
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Returns true if the view is not a view template. |