Creates a new placeholder duct.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- systemTypeId
- Type: Autodesk.Revit.DB ElementId
The id of the HVAC system type.
- ductTypeId
- Type: Autodesk.Revit.DB ElementId
The id of the duct type.
- levelId
- Type: Autodesk.Revit.DB ElementId
The level id for the duct.
- startPoint
- Type: Autodesk.Revit.DB XYZ
The first point of the placeholder line.
- endPoint
- Type: Autodesk.Revit.DB XYZ
The second point of the placeholder line.
Return Value
The created placeholder duct.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The systemTypeId is not valid HVAC system type. -or- The duct type ductTypeId is not valid duct type. -or- The ElementId levelId is not a Level. -or- The points of startPoint and endPoint are too close: for MEPCurve, the minimum length is 1/10 inch. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |