Gets a RebarHostData object referring to the specified rebar host element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- host
- Type: Autodesk.Revit.DB Element
An element to host rebar.
Return Value
A RebarHostData object, or a null reference ( Nothing in Visual Basic) .Remarks
Returns a null reference ( Nothing in Visual Basic) for elements that cannot ever be rebar hosts, such as levels.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |