This method is used to get a Reference from an adjacent MassZone that is coincident to a Reference of this MassZone.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- referenceToZoneFace
- Type: Autodesk.Revit.DB Reference
Reference to face of MassZone.
Return Value
Reference to coincident face of adjacent MassZone or a null reference ( Nothing in Visual Basic) if there is no adjacent MassZone face Reference.Remarks
The result is always a Reference to a Face. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE. The results are always references to Faces.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input Reference is not a face Reference of this MassZone. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |