Sets the elements which the dimension will witness.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elementsToDimension
- Type: System.Collections.Generic ICollection ElementId
The elements which the dimension will witness.
Remarks
The dimension will automatically find geometric references in the elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | some elements do not match the reference category required by the MultiReferenceAnnotationType. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The MultiReferenceAnnotationType assigned to the options can't create MultiReferenceAnnotations by element. |