Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- entry
- Type: Autodesk.Revit.DB KeyBasedTreeEntry
The entry to be added.
Return Value
Returns true if an entry is added into the entry data set successfully, returns false if an entry fails to be added because this entry is invalid or a duplicate of one in the entry data set.Remarks
The entry will not be added if it is invalid or duplicate with the added entries.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The KeyBasedTreeEntry object is not appropriate to be added in this KeyBasedTreeEntriesLoadContent. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already. Adding more KeyBasedTreeEntries as well as repeated building, is not supported. |