Instantiates a StairsEditScope object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document for which this StairsEditScope is going to be used.
- transactionName
- Type: System String
The name that will appear in the Undo menu in Revit after the StairsEditScope is successfully committed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | document is not a primary document, it is a linked document. -or- document is not a project document. -or- transactionName is an empty string. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |