Autodesk.Revit.UI.Events Namespace


Classes

Class Description
Public class ApplicationClosingEventArgs
The event arguments used by the ApplicationClosing event.
Public class BeforeExecutedEventArgs
The event arguments used by AddInCommandBinding's BeforeExecuted event.
Public class CanExecuteEventArgs
The event arguments used by AddInCommandBinding's CanExecute event.
Public class ComboBoxCurrentChangedEventArgs
The event arguments used by ComboBox's CurrentChanged event.
Public class ComboBoxDropDownClosedEventArgs
The event arguments used by ComboBox's DropDownClosed event.
Public class ComboBoxDropDownOpenedEventArgs
The event arguments used by ComboBox's DropDownOpened event.
Public class CommandEventArgs
The base class of the command Executed and CanExecute event arguments.
Public class DialogBoxData
An object that is passed to your application when a dialog is displayed in Revit.
Public class DialogBoxShowingEventArgs
The base class for the event arguments used by the DialogBoxShowing event.
Public class DisplayingOptionsDialogEventArgs
The event arguments used by DisplayingOptionDialog event.
Public class DockableFrameFocusChangedEventArgs
The event arguments used by the DockableFrameActivatedChanged event.
Public class DockableFrameVisibilityChangedEventArgs
The event arguments used by the DockableFrameVisibilityChanged event.
Public class ExecutedEventArgs
The event arguments used by AddInCommandBinding's Executed event.
Public class FabricationPartBrowserChangedEventArgs
The event arguments used by the FabricationPartBrowserChangedEventArgs event.
Public class FormulaEditingEventArgs
The event arguments used by the DocumentSaving event.
Public class IdlingEventArgs
The event arguments used by the Idling event.
Public class MessageBoxData
An object that represents a simple message box that prompts the user for some action.
Public class MessageBoxShowingEventArgs
The event arguments used by the DialogBoxShowing event when a Windows message box is about to be displayed in Revit.
Public class RibbonItemEventArgs
The base class of the RibbonItem event arguments which have UIApplication property.
Public class TaskDialogShowingEventArgs
The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.
Public class TextBoxEnterPressedEventArgs
The event arguments used by TextBox's EnterPressed event.
Public class TransferredProjectStandardsEventArgs
The event arguments used by the TransferredProjectStandards event.
Public class TransferringProjectStandardsEventArgs
The event arguments used by the TransferringProjectStandards event.
Public class ViewActivatedEventArgs
The event arguments used by the ViewActivated event.
Public class ViewActivatingEventArgs
The event arguments used by the ViewActivating event.

Enumerations

Enumeration Description
Public enumeration FabricationPartBrowserOperation
Operations for the FabricationPartBrowserChangedEventArgs Event