WallSweepOrientation Property


Indicates how the profile of a horiztonal sweep is oriented with repect to the wall side face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public WallSweepOrientation WallSweepOrientation { get; set; }
Visual Basic
Public Property WallSweepOrientation As WallSweepOrientation
	Get
	Set
Visual C++
public:
property WallSweepOrientation WallSweepOrientation {
	WallSweepOrientation get ();
	void set (WallSweepOrientation value);
}

Field Value

Allowed values are Horizontal and Perpendicular. Default is Perpendicular

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also