FileName Property


File name of the PDF when Combine is true ( True in Visual Basic) .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
	Get
	Set
Visual C++
public:
property String^ FileName {
	String^ get ();
	void set (String^ value);
}

Remarks

PDF file extension (".pdf") would be automatically appended to the result file. When Combine is false ( False in Visual Basic) , this would be ignored.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also