Specifies a direction for manipulating analytical model.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Vertical | Change in vertical direction only. |
VerticalTop | Vertical change, for top of Element's analytical model. |
VerticalBottom | Vertical change, for bottom of Element's analytical model. |
Horizontal | Change in horizontal direction only (no elevation change). |
HorizontalStart | Horizontal change, corresponding to start of Curve Driver. |
HorizontalEnd | Horizontal change, corresponding to end of Curve Driver. |
Any | Any change, including vertical and horizontal. |
X | Change in X direction |
Y | Change in Y direction |
Z | Change in Z direction |