The type of placement required for a given family.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
OneLevelBased | The family is placed referencing a single level. |
OneLevelBasedHosted | The family is placed referencing a single level and host. |
TwoLevelsBased | The family is placed referencing two levels (e.g. a column). |
ViewBased | The family is view-specific (e.g. a detail annotation) |
WorkPlaneBased | The family is placed on a work plane or face. |
CurveBased | The family is based on a line and placed on a work plane. |
CurveBasedDetail | The family is based on a line and place on a specific view (e.g. a detail component). |
CurveDrivenStructural | The family is a structural curve driven member (beam, brace, or slanted column) |
Adaptive | The family is an adaptive family. |
Invalid | This signals an invalid value for the enum. |