Applies to this view the parameters of the input view that are not controlled by the current view template.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- otherView
- Type: Autodesk.Revit.DB View
The view whose parameters are to be applied to this view. It does not have to be a valid template (property IsTemplate can be true or false).
Remarks
Apply the view template parameters is a one-time operation, the association between the views is not preserved. To get all template parameters call GetTemplateParameterIds on the template. To get parameters that are not controlled by the template call GetNonControlledTemplateParameterIds on the template. To get current view template of this view use property ViewTemplateId .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |