Creates a new linear array element from a single element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DB Document
The document.
- dBView
- Type: Autodesk.Revit.DB View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
- id
- Type: Autodesk.Revit.DB ElementId
The element to array.
- count
- Type: System Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
- translationToAnchorMember
- Type: Autodesk.Revit.DB XYZ
The translation vector for the array.
- anchorMember
- Type: Autodesk.Revit.DB ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.
Return Value
The new linear array element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | Failed to create the linear array. |