Scales the basis vectors of this transformation and returns the result.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- scale
- Type: System Double
The scale value.
Return Value
The transformation equal to the composition of the two transformations.Remarks
The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when the specified value is an infinite number. |