Perform Manual Analytical Adjustment on analytical model, with respect to another Element
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- source
- Type: Autodesk.Revit.DB Reference
Which part of Analytical Model needs to change.
- target
- Type: Autodesk.Revit.DB Reference
Which part of another Analytical Model change should be made against.
Return Value
Indicates the successful completion of the Manual Analytical Adjustment operation. True if source Element was adjusted successfully, false otherwise.Remarks
Success is achieved when the Source adjusts itself against the Target. Additionally, this requires an open transaction on the current document. Model regeneration is required after the operation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if source cannot be used as source reference, or if target cannot be used as target reference. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |