Creates a new instance of Z Cold Formed shape.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- width
- Type: System Double
Section width.
- height
- Type: System Double
Section height, depth.
- wallNominalThickness
- Type: System Double
Represents wall nominal thickness of rectangle.
- wallDesignThickness
- Type: System Double
Represents wall design thickness of rectangle.
- innerFillet
- Type: System Double
Inner Fillet - Corner fillet inner radius.
- bottomFlangeLength
- Type: System Double
Bottom Flange segment length.
- lipLength
- Type: System Double
Lip segment length.
- centroidHorizontal
- Type: System Double
Distance from centroid to the left extremites along horizontal axis.
- centroidVertical
- Type: System Double
Distance from centroid to the upper extremites along vertical axis.
- analysisParams
- Type: Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionAnalysisParams
Common set of parameters for structural analysis.