Current Property


Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public virtual KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo> Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportLinetypeKey, ExportLinetypeInfo)
	Get
Visual C++
public:
virtual property KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^> Current {
	KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^> get ();
}

Implements

IEnumerator T Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException There is no current item in the iterator.

See Also