Shrinks the multistory stairs by disconnecting input levels.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- levelIds
- Type: System.Collections.Generic ISet ElementId
The level ids.
Remarks
If you remove a stairs that is connected at the top and bottom to another level stairs, the remaining stairs will automatically adjust to maintain the multistory stairs. The stairs above the one that is removed extends to attach to the stairs on the level below the one that is removed. You cannot disconnect the levels of standard stair (the stair associated with the Reference Level for the multistory stairs) or already disconnected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This multistory stairs cannot disconnect from one or more members of levelIds. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |