Prompts the user to select elements to change them to the input type.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elementType
- Type: Autodesk.Revit.DB ElementType
The ElementType applied to selected instances.
Remarks
This method uses its own transaction, so it's not permitted to be invoked in an active transaction. In a single invocation, the user can select multiple elements to be modified to the given type, until they finish.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | This document is not the currently active one. -or- Starting a new transaction is not permitted. It could be because another transaction already started and has not been completed yet, or the document is in a state in which it cannot start a new transaction. |