GetValue Method


Gets a collection of properties stored in this property list. These properties are copied.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2014

Syntax

C#
public IList<AssetProperty> GetValue()
Visual Basic
Public Function GetValue As IList(Of AssetProperty)
Visual C++
public:
IList<AssetProperty^>^ GetValue()

Return Value

Returns a copy of all the properties in this AssetPropertyList.

Remarks

All the properties in the list are of the same AssetPropertyType. The AssetPropertyType can only be Integer, Double4, Float or Double, Enumeration.

See Also