GetAnnotationCropShape Method


Gets the annotation crop box assigned to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public CurveLoop GetAnnotationCropShape()
Visual Basic
Public Function GetAnnotationCropShape As CurveLoop
Visual C++
public:
CurveLoop^ GetAnnotationCropShape()

Return Value

The annotation crop boundary.

Remarks

Currently, this method returns only the rectangular annotation crop box.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException View is not allowed to have an annotation crop.

See Also