AddTriangle Method


Inserts a IndexTriangle into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017

Syntax

C#
public void AddTriangle(
	IndexTriangle triangle
)
Visual Basic
Public Sub AddTriangle ( _
	triangle As IndexTriangle _
)
Visual C++
public:
void AddTriangle(
	IndexTriangle^ triangle
)

Parameters

triangle
Type: Autodesk.Revit.DB.DirectContext3D IndexTriangle
The triangle to be inserted.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null
Autodesk.Revit.Exceptions InvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also