Constructs an instance of FilterStringRule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- valueProvider
- Type: Autodesk.Revit.DB FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
- evaluator
- Type: Autodesk.Revit.DB FilterStringRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests for strings such as begins-with, ends-with, contains, equal, etc.
- ruleString
- Type: System String
The user-supplied string against which strings from a Revit document will be tested.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |