Loads the contents of a classification text file into the provided KeyBasedTreeEntriesLoadContent.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filePath
- Type: System String
The full path of the existing classification file.
- loadContent
- Type: Autodesk.Revit.DB KeyBasedTreeEntriesLoadContent
The classification entries read from the filePath will be added to this object. A KeyBasedTreeEntriesLoadContent object will also be updated to contain status information, including information about any errors that occurred while reading the keynote entries from the specified file.
Return Value
True if reading the keynote file succeeds; False if the classification file cannot be read.Remarks
The entries read from the file will be added to any existing entries read from other files before this reading operation in the provided KeyBasedTreeEntriesLoadContent. if file A was read, and then file B was failed to read, all the entries from file A will still be there to build KeynoteEntries object.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | filePath is an empty string. -or- The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already. Adding more KeyBasedTreeEntries as well as repeated building, is not supported. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidPathArgumentException | The destination file name includes one or more invalid characters. |