Adds Member Forces to element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- start
- Type: System Boolean
Member Forces position on analytical model stick element. True for start, false for end.
- force
- Type: Autodesk.Revit.DB XYZ
The translational forces at specified position of the element. The x value of XYZ object represents force along x-axis of the analytical model coordinate system, y along y-axis, z along z-axis respectively.
- moment
- Type: Autodesk.Revit.DB XYZ
The rotational forces at specified position of the element. The x value of XYZ object represents moment about x-axis of the analytical model coordinate system, y about y-axis, z about z-axis respectively.
Remarks
If element already have member forces defined for that end, newly provided values replace current one. Member forces are strictly related with releases. This means that setting member forces values is reasonable only for directions that have releases set to false.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |