Creates a new workset.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which the new instance is created.
- name
- Type: System String
The workset name.
Return Value
Returns the newly created workset.Examples

public Workset CreateWorkset(Document document)
{
Workset newWorkset = null;
// Worksets can only be created in a document with worksharing enabled
if (document.IsWorkshared)
{
string worksetName = "New Workset";
// Workset name must not be in use by another workset
if (WorksetTable.IsWorksetNameUnique(document, worksetName))
{
using (Transaction worksetTransaction = new Transaction(document, "Set preview view id"))
{
worksetTransaction.Start();
newWorkset = Workset.Create(document, worksetName);
worksetTransaction.Commit();
}
}
}
return newWorkset;
}

Public Function CreateWorkset(document As Document) As Workset
Dim newWorkset As Workset = Nothing
' Worksets can only be created in a document with worksharing enabled
If document.IsWorkshared Then
Dim worksetName As String = "New Workset"
' Workset name must not be in use by another workset
If WorksetTable.IsWorksetNameUnique(document, worksetName) Then
Using worksetTransaction As New Transaction(document, "Set preview view id")
worksetTransaction.Start()
newWorkset = Workset.Create(document, worksetName)
worksetTransaction.Commit()
End Using
End If
End If
Return newWorkset
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | document is not a workshared document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters. -or- The given workset name is already in use. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |