InCanvasControlData Class


Represents a collection of data which is used by [!:Autodesk::Revit::DB::TemporaryGraphicsManager] to create and update an in-canvas control.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public class InCanvasControlData : IDisposable
Visual Basic
Public Class InCanvasControlData _
	Implements IDisposable
Visual C++
public ref class InCanvasControlData : IDisposable

Remarks

So far, only bitmap file is supported for ImagePath . The rendered image is the same size in pixel dimensions as the original one. To get a better result, the caller should prepare the image with proper size, for exmaple: 32x32 or 64x64 in pixels, before use. To achive a "transparent" backgound color effect over the provided bitmap, the bitmap should use color RGB(0, 128, 128) as its background and it will be cleared during rendering by Revit.

Inheritance Hierarchy

System Object
Autodesk.Revit.DB InCanvasControlData

See Also