Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- datumEnd
- Type: Autodesk.Revit.DB DatumEnds
Specifies one end of the curve representing the datum plane in the view.
- view
- Type: Autodesk.Revit.DB View
The view in which to set the datum extent settings.
- extentMode
- Type: Autodesk.Revit.DB DatumExtentType
The DatumExtentType.
Remarks
In a particular view, the datum plane is represented by a curve and the two ends of the curve may have different DatumExtentTypes in that view. If the value is changed from DatumExtentType::Model to DatumExtentType::ViewSpecific, then the view specific extents will be identical to the model extent until modified.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The datum plane cannot be visible in the view. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |