SetValueAsXYZ Method


Sets the value property as a vector or point XYZ.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)

Syntax

C#
public void SetValueAsXYZ(
	XYZ xyz
)
Visual Basic
Public Sub SetValueAsXYZ ( _
	xyz As XYZ _
)
Visual C++
public:
void SetValueAsXYZ(
	XYZ^ xyz
)

Parameters

xyz
Type: Autodesk.Revit.DB XYZ
The new value.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The input value is invalid for this AssetPropertyDoubleArray3d property.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null
Autodesk.Revit.Exceptions InvalidOperationException The asset property is not editable.

See Also