Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- source
- Type: Autodesk.Revit.DB Reference
Reference to be examined.
- adjustmentDirection
- Type: Autodesk.Revit.DB.Structure AnalyticalDirection
Direction in which adjustment will occur.
Return Value
True if reference can be used as source; false otherwise.Remarks
This method is useful for determining if a reference is acceptable for usage as a "Source". In other words, if the reference identifies an Analytical Model portion that can be adjusted by the user.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment. |